相信很多人都使用过贷款,不管是网贷还是信用贷,或者信用卡贷款都是我们用的比较多,申请次数比较多的口子

商汇网-最专业的项目分享平台

您现在的位置是:首页>财经

财经

追涨热度指标公式计算(追涨热度指标公式)

admin2022-09-23 06:45:13财经18来源:商汇网

今天给各位分享追涨热度指标公式的知识,其中也会对追涨热度指标公式计算进行解释,如果能碰巧解决你现在面临的问题,别忘了关注本站,现在开始吧!

本文目录一览

分时追涨公式

四个分时指标公式:

★分时雄起!分时走势上部主图专用!

ma5:ma(c,5);

ma10:ma(c,10);

ma20:ma(c,20);

ma30:ma(c,30);

ma60:ma(c,60);

ma120:ma(c,120);

fa:=barslast(cross(ma10,ma5)) and cross(ma5,ma10);

fb:=fa and ma5ma30 and ma10ma30 and ma10ref(ma10,1);

STICKLINE(fb,l,l-0.09,4,0),COLORYELLOW;

DRAWTEXT(fb,l-0.13,'雄起'),COLORYELLOW;

fa2:=barslast(cross(ma60,ma20)) and cross(ma20,ma60);

fb2:=fa2 and ma20ma120 and ma60ma120 and ma20ref(ma20,1);

STICKLINE(fb2,l,l-0.09,4,0),COLORYELLOW;

DRAWTEXT(fb2,l-0.13,'雄起'),COLORYELLOW;

★实战分时!下部专用!可做进一步简化处理!

input:LONG(26,1,100),SHORT(12,1,100),M(9,1,100),p1(19,1,100),p2(120,1,250);

DIF:EMA(CLOSE,SHORT) - EMA(CLOSE,LONG);

DEA:=EMA(DIF,M);

MACD:=2*(DIF-DEA);

MACD2:2*(DEA-DIF),COLORFF89B2,DOTLINE;

MA5:=MA(CLOSE,5);

MA10:=MA(CLOSE,10);

MA30:=MA(CLOSE,30);

MA60:=MA(CLOSE,60);

MA65:=MA(CLOSE,65);

MA250:=MA(CLOSE,250);

突破线:=MIN(MA60*1.1,MA250*1.3);

差幅:=C/MIN(MA60*1.1,MA250*1.3)-1;

均线流:=(MA5MA65 AND MA10MA65 AND MA30MA65 AND MA5MA30)*0.3;

PL1:=(CLOSE - MA60) / MA60 0.1;

PL2:=(CLOSE - MA250) / MA250 0.3;

偏离率:(PL1 = 1 AND PL2 = 1) * 0.2,STICK,COLORFF00FF,LINETHICK2;

MACD超跌:=COUNT((DIFDEA),10)=10;

MACD1:MACD超跌 * "MACD.MACD"(LONG,SHORT,M)*(-1),COLOR009900,LINETHICK2;

目标:IF(均线流=0.3 AND MACD超跌 AND 偏离率=0.2 ,0.8,0),COLOR7070FF,LINETHICK2;

MBSJ:=BARSLAST(目标 = 0.8);

放量上涨:=V/REF(V,1) = 1.1 AND C/REF(C,1) = 1.01;

SZSJ:=BARSLAST(放量上涨 = 1);

MACD雄起:=CROSS(DIF,DEA);

JCSJ:=BARSLAST(MACD雄起 = 1);

关注:(MACD雄起 AND REF(MACD1,1) 0)*-0.1,COLOR00FF00;

启动:(MBSJ = 20 AND SZSJ = 1 AND JCSJ = 1) * 1,COLORFFFF00,LINETHICK2;

突破:(偏离率 = 0 AND REF(COUNT(偏离率 = 0.2,10) = 10,1) = 1) * -0.1,COLORRED;

STICKLINE(偏离率 = 0.2,0,0.2,1,0),colorFF00FF;

DRAWTEXT(关注=-0.1,-0.01,'关●注'),color00ff00;

DRAWTEXT(启动,0.8,'★买'),colorFFFF00;

DRAWTEXT(突破=-0.1,-0.01,'突●破'),colorred;

N15HIGH:=REF(HIGH,15);

N1LOW:=REF(LOW,1);

FF:=(((N15HIGH - N1LOW) / N1LOW) 0.15);

DRAWICON((((((CROSS(MA(CLOSE,P1),MA(CLOSE,P2)) 0) AND (((N15HIGH - N1LOW) / N1LOW)

0.15)) AND (OPEN = MA(CLOSE,P1))) AND (CLOSE = MA(CLOSE,P1))) AND (LOW = MA

(CLOSE,P1))),0.5,1);

DRAWTEXT((((((CROSS(MA(CLOSE,P1),MA(CLOSE,P2)) 0) AND (((N15HIGH - N1LOW) / N1LOW)

0.15)) AND (OPEN = MA(CLOSE,P1))) AND (CLOSE = MA(CLOSE,P1))) AND (LOW = MA

(CLOSE,P1))),0.5,'★^回头望月'),color0099CC;

低位雄起:CROSS(DIF,DEA) AND DIF-0.1,colorwhite;

STICKLINE(低位雄起,0,0.08,6,0),COLORwhite;

DRAWTEXT(低位雄起,低位雄起-1.5,' 低位雄起'),COLORWHITE;

JCCOUNT:=COUNT(CROSS(DIF,DEA),BARSLAST(DEA=0));

雄起:CROSS(DIF,DEA) AND DEA0 AND COUNT(JCCOUNT=2,21)=1,coloryellow;

STICKLINE(雄起,0,0.06,6,0),ColorFF00FF;

DRAWICON(雄起,dea*1.04,1) ;

DRAWTEXT(雄起,0.5,' 雄起'),ColorYELLOW;

if(dif0,dif,0),coloryellow,linethick2;

if(dif0,0,dif),colorred,linethick2;

if(difdea,dif,dea),COLORWHITE,linethick2;

if(difdea,dea,dea),COLORFF9933{colorff00ff},linethick2;

操盘:STICKLINE(MACD=0 AND MACD=REF(MACD,1),0,MACD,4,1),COLORRED{COLOR6058FF};

减仓:STICKLINE(MACD=0 AND MACD REF(MACD,1),0,MACD,4,0),COLORblue{COLOR6058FF};

反弹:STICKLINE(MACD0 AND MACD=REF(MACD,1),0,MACD,4,1),COLORYELLOW{COLORFFFF00};

寻底:STICKLINE(MACD0 AND MACD REF(MACD,1),0,MACD,4,0),COLORFFFF00;

空仓:0,COLORWHITE;

★分时机密!下部专用!可做进一步简化处理!多用于开盘就抓涨!

V1:=(C*2+H+L)/4*10;

V2:=EMA(V1,13)-EMA(V1,34);

V3:=EMA(V2,5);

V4:=2*(V2-V3)*5.5;

庄秘撤: IF(V4=0,V4,0),COLOR00FF00,LINETHICK2;

庄秘进: IF(V4=0,V4,0),COLORFF00FF,LINETHICK2;

V5:=(HHV(INDEXH,8)-INDEXC)/(HHV(INDEXH,8)-LLV(INDEXL,8))*8;

V6:=EMA(3*V5-2*SMA(V5,18,1),5);

V7:=(INDEXC-LLV(INDEXL,8))/(HHV(INDEXH,8)-LLV(INDEXL,8))*10;

V8:=(INDEXC*2+INDEXH+INDEXL)/4;

V9:=EMA(V8,13)-EMA(V8,34);

VA:=EMA(V9,3);

VB:=(V9-VA)/2;

大筹金进场: IF(VB=0,VB,0),COLORYELLOW,LINETHICK2;

大筹金撤走: IF(VB=0,VB,0),COLORBLUE,LINETHICK2;

aa:=WINNER(CLOSE+CLOSE*15/100)*100;

bb:=WINNER(CLOSE+CLOSE*0/100)*100;

cc:=aa-bb;

dd:=(WINNER(CLOSE-CLOSE*0.1/100)-WINNER(CLOSE-CLOSE*15/100))*100;

ee:=cc3 and dd0.5 and OPENLOW;

a1:=DYNAINFO(6);

a2:=IF(LOWa1,0,IF(HIGHa1,1,(a1-LOW+0.01)/(HIGH-LOW+0.01)));

a3:=VOL/WINNER(LOW);

a4:=REF(HHV(CLOSE,120),1);

a5:=REF(LLV(CLOSE,120),1);

a6:=100*(CLOSE-a5)/(a4-a5);

a7:=a20 or a2=1;

a8:=a7 and a3/REF(a3,3)=3 and a680;

a9:=REF(a8,1) or REF(a8,2) or REF(a8,3) or REF(a8,4);

a10:=a8 and a9;

a11:=IF(FILTER(a8,3),5,0);

a12:=IF(FILTER(a10,3) or ee,10,0);

筹码进场日:IF(a11,8,0),LINETHICK0;

STICKLINE(a12,0,15,5,0),colorff00ff;

筹码加仓日:IF(a12,88,0),LINETHICK0;

STICKLINE(a12,0,15,5,0),colorff00ff;

STICKLINE(a11,0,5,5,0),colorff7700;

STICKLINE(a11,0,5,4.5,0),colorff8800;

STICKLINE(a11,0,5,4,0),colorff9900;

STICKLINE(a11,0,5,3.5,0),colorffaa00;

STICKLINE(a11,0,5,3,0),colorffbb00;

STICKLINE(a11,0,5,2.5,0),colorffcc00;

STICKLINE(a11,0,5,2,0),colorffdd00;

STICKLINE(a11,0,5,1,0),colorffee00;

STICKLINE(a12,0,15,4.5,0),color102099;

STICKLINE(a12,0,15,4,0),color1020aa;

STICKLINE(a12,0,15,3.5,0),color1020bb;

STICKLINE(a12,0,15,3,0),color1020cc;

STICKLINE(a12,0,15,2.5,0),color1020dd;

STICKLINE(a12,0,15,2,0),color1020ee;

STICKLINE(a12,0,15,1,0),color1020ff;

DRAWTEXT(a11,8,'筹码进场');

DRAWTEXT(a12,17,'筹码加仓');

Var1:=REF(LOW,1);

Var2:=SMA(ABS(LOW-Var1),13,1)/SMA(MAX(LOW-Var1,0),13,1)*4;

Var3:=EMA(Var2,13);

Var4:=LLV(LOW,34);

Var5:=EMA(IF(LOW=Var4,Var3,0),3);

主力进场:

STICKLINE(Var5REF(Var5,1),0,Var5,7,0 ),COLORRED;

洗盘:IF(VAR5REF(VAR5,1),VAR5,0),COLORGREEN,LINETHICK2;

STICKLINE(VAR5REF(VAR5,1),0,VAR5,2,1),COLORGREEN;

Var6:=100-3*SMA((CLOSE-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1)+2*SMA(SMA((CLOSE-

LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1),15,1);

Var7:=100-3*SMA((OPEN-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1)+2*SMA(SMA((OPEN-LLV

(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1),15,1);

Var8:=Var6REF(Var7,1) AND VOLREF(VOL,1) AND CLOSEREF(CLOSE,1);

DRAWTEXT(Var8 AND COUNT(Var8,30)=1,40,'★注意有筹码进场迹象');

★分时作为!(专门监视庄家行动变化)同时也可用于买入信号观注点!

Var1:=EMA(EMA(CLOSE,13),13);

作为:=(Var1-REF(Var1,1))/REF(Var1,1)*1000;

无庄作为:STICKLINE(作为0,作为,0,4,0),colorwhite;

有庄作为:STICKLINE(作为REF(作为,1) AND 作为0,作为,0,4,1),colorred;

Var2:=100*WINNER(CLOSE*0.95);

出货作为:STICKLINE(作为REF(作为,1) AND 作为0,作为,0,4,0),color00ff00;

高度作为:STICKLINE(Var250 AND COST(85)CLOSE AND 作为0,作为,0,4,0),colorff00ff;

a10:=CROSS(作为,0);

开始作为:if(a10,6,0),coloryellow;

★分时实战

input:LONG(24,1,100),SHORT(13,1,100),M(6,1,100),N(6,1,100);

MA5:=MA(CLOSE,5);

MA10:=MA(CLOSE,10);

MA20:=MA(CLOSE,20);

MA30:=MA(CLOSE,30);

DIF:EMA(CLOSE,SHORT) - EMA(CLOSE,LONG);

DEA:EMA(DIF,M);

MACD:=2*(DIF-DEA);

Q:2*(DEA-DIF),COLORFF9933;

MACD超跌:=COUNT((DIFDEA),10)=10;

Q1:MACD超跌 * "MACD.MACD"(LONG,SHORT,M),COLORFF00FF,LINETHICK2;

{本行中,大智慧版本选择*(-1);飞弧版本选择*(1)}

MACD金叉:=CROSS(DIF,DEA);

DTPL:=MA10MA30 AND MA20MA30 AND MA30REF(MA30,1);

关注:=(MACD金叉 AND REF(Q1,1) 0)*-0.1;

均线:(DTPL AND MA5MA30 AND MA5MA10)*-0.15,colorFF89B2,LINETHICK1,PRECIS2,DOTLINE;

偏离:(CMIN(MA20*1.05,MA30*1.1) AND CMA30)*0.15,COLOR009900,LINETHICK1,PRECIS2,DOTLINE;

DRAWTEXT(关注,-0.15,'GZ'),color00ff00,align1;

BDGD:=C=HHV(C,20);

GDSJ:=BARSLAST(BDGD);

目标:IF(均线 AND 偏离 AND GDSJ=N,0.5,0),COLORffff00,POINTDOT,PRECIS1,LINETHICK3;

MBSJ:=BARSLAST(目标);

MAV5:=EMA(V,5);

MAV10:=EMA(V,10);

LNMACD:=((V-MAV5)/MAV5*2+(V-MAV10)/MAV10)*10;

量坑:=LNMACD=-10;

优选:=目标 AND COUNT(量坑,3)=1;

DRAWICON(优选,-0.2,12);

N15HIGH:=REF(HIGH,6);

N1LOW:=REF(LOW,1);

DRAWTEXT((((((CROSS(MA(CLOSE,13),MA(CLOSE,24)) 0) AND (((N15HIGH - N1LOW) / N1LOW)

0.15)) AND (OPEN = MA(CLOSE,13))) AND (CLOSE = MA(CLOSE,13))) AND (LOW = MA

(CLOSE,13))),0.5,'^回头望月'),color0099CC;

低位金叉:=CROSS(DIF,DEA) AND DIF-0.1;

STICKLINE(低位金叉,0,0.26,6,1),COLORwhite;

DRAWTEXT(低位金叉,低位金叉-1.3,' 低金'),COLORWHITE;

JCCOUNT:=COUNT(CROSS(DIF,DEA),BARSLAST(DEA=0));

二次金叉:=CROSS(DIF,DEA) AND DEA0 AND COUNT(JCCOUNT=2,21)=1;

STICKLINE(二次金叉,0,0.2,4,0),ColorFF00FF;

DRAWTEXT(二次金叉,0.4,' 二金'),ColorYELLOW;

A4:=BARSLAST(ref(cross(dif,dea),1));

B1:=ref(c,A4+1)c and ref(dif,A4+1)dif and cross(dif,dea);

DRAWTEXT(FILTER(B10,5),dif+0.2,'背离'),COLORyellow;

STICKLINE(MACD=0 AND MACD=REF(MACD,1),0,MACD,3,0),COLORRED{COLOR6058FF};

STICKLINE(MACD=0 AND MACD REF(MACD,1),0,MACD,3,0),COLORblue{COLOR6058FF};

STICKLINE(MACD0 AND MACD=REF(MACD,1),0,MACD,3,0),COLOR4ABEFF{COLORFFFF00};

STICKLINE(MACD0 AND MACD REF(MACD,1),0,MACD,3,0),COLORFFFF00;

RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;

K:=SMA(RSV,3,1);

D:=SMA(K,3,1);

J:=3*K-2*D;

周K:=MA(".K#WEEK"(9,3,3) ,5);

周D:=MA(".D#WEEK"(9,3,3) ,5);

周J:=MA(".J#WEEK"(9,3,3) ,5);

DRAWICON(k20 and cross(k,d),MACD,1),align2;

周金RAWTEXT(CROSS(".K#WEEK"(9,3,3),".D#WEEK"(9,3,3)) ,MACD,'▲'),align2,COLORred;

周死RAWTEXT(CROSS(".d#WEEK"(9,3,3),".k#WEEK"(9,3,3))

,macd*1.5,'▼'),align2,COLORgreen;

月金RAWTEXT(CROSS(".K#MONTH"(9,3,3),".D#MONTH"(9,3,3))

,MACD,'▲'),align2,COLORMAGENTA;

月死:DRAWTEXT(CROSS(".D#MONTH"(9,3,3),".K#MONTH"(9,3,3))

,macd*1.5,'▼'),align2,COLOR3fbb8b;

if(dif0,dif,0),coloryellow,linethick2;

if(dif0,0,dif),colorred,linethick2;

if(difdea,dif,dea),COLORWHITE,linethick2;

if(difdea,dea,dea),COLORgreen{colorff00ff},linethick2;

HH:=MA(CLOSE,10);

GG:=MA(CLOSE,12);

上:=ema((MA(HIGH,3) * 1.05),30);

下:=ema((MA(LOW,3) * 0.96),30);

决战:STICKLINE((((CROSS(DIF,DEA) AND ((下 - REF(下,1)) 0)) AND (MACD = REF(MACD,1))) AND

(DIF 0)),DIF,0.3,1,0),color0000FF;

{DRAWICON((((CROSS(DIF,DEA) AND ((下 - REF(下,1)) 0)) AND (MACD = REF(MACD,1))) AND (DIF

0)),0.4,0);}

DRAWTEXT((((CROSS(DIF,DEA) AND ((下 - REF(下,1)) 0)) AND (MACD = REF(MACD,1))) AND (DIF

= 0)),0.3,'DIF金叉'),color0000FF;

STICKLINE(FILTER(((((MACD = REF(MACD,5)) AND ((下 - REF(下,1)) 0)) AND (MACD = 0)) AND

((GG - REF(GG,1)) = 0)),3),0,0.4,1,0),color00FF00;

{DRAWICON(FILTER(((((MACD = REF(MACD,5)) AND ((下 - REF(下,1)) 0)) AND (MACD = 0)) AND

((GG - REF(GG,1)) = 0)),3),0.5,0);}

DRAWTEXT(FILTER(((((MACD = REF(MACD,5)) AND ((下 - REF(下,1)) 0)) AND (MACD = 0)) AND

((GG - REF(GG,1)) = 0)),3),0.4,'绝佳买入'),color00FF00;

市场能量指标CYF的公式是什么?

市场能量指标CYF的公式如下:

n:=13;

HSL:=100*VOL/capital;

CYF:100-100/(1+EMA(HSL,N))

市场能量指标CYF:市场能量指标CYF 如果说CYQ和CYW常常用于研究主力的话,那么CYF反映的是市场公众的状态。它叫市场能量指标。这个指标的设计思想认为形成一个多头市场的基础必须是市场的活跃,如果存在一个市场的多头能量的话,那么它一定和成交量相关。

1.CYF反映了市场公众的状态和追涨热情,又称市场能量指标。

2.使用CYF判断股票的活跃程度, CYF小于10的股票是冷门股,CYF在20到40之间是活跃股,CYF大于50是热门股。

3.CYF与股价顶背离时,易形成反转。

求一个追高指标公式

送你一个吧,不过没有选股,下面网址里有演示图片,可以先看看效果.

通达信短线追涨指标公式

获利比:=MA(WINNER(CLOSE)*100,5);

获利均线:=SMA(获利比,3,1);

一天线:=MA(C,1);

快线:MA((3*SMA((C- LLV(L,9))/(HHV(HIGH,9)-LLV(LOW,9))*100,3,1)-2*SMA(SMA((C-LLV(L,9))/(HHV(HIGH,9)-LLV(LOW,9))*100,3,1),3,1)),2),COLORRED,LINETHICK2;

操盘线:MA(3*SMA((C-LLV(L,21))/(HHV(H,21)-LLV(L,21))*100,5,1)-2*SMA(SMA((C- LLV(L,21))/(HHV(H,21)-LLV(L,21))*100,5,1),3,1),3),LINETHICK2;

通用操盘线:MA(3*SMA((C- LLV(L,27))/(HHV(H,27)-LLV(L,27))*100,5,1)-2*SMA(SMA((C-LLV(L,27))/(HHV(H,27)-LLV(L,27))*100,5,1),3,1),5),COLORBLUE,LINETHICK2;

VAR1:=(C*3+H+L+O)/6;

VAR2:=SMA(MAX(C-VAR1,0),8,1)/SMA(ABS(C-VAR1),8,1)*100;

VAR3:=100*(HHV(H,15)-C)/(HHV(H,13)-LLV(L,13))-45;

VAR4:=BARSLAST(CROSS(C,MA(C,21)));

VAR5:=BARSLAST(CROSS(MA(C,21),C));

VAR6:=IF(VAR4VAR5,VAR4+1,0);

VAR7:=(C-REF(C,VAR6))/REF(C,VAR6)*100;

买入关注:IF(通用操盘线5,10,0),COLORGREEN;

卖出关注:IF(通用操盘线80,90,100),COLORGREEN;

IF(COUNT(获利均线2,10)=9 AND CROSS(获利比,获利均线),20,0);

DRAWTEXT(CROSS(操盘线,通用操盘线)AND 通用操盘线10,20,'买点'),COLORRED;

DRAWICON(CROSS(通用操盘线,操盘线)AND 通用操盘线90,100,2);

DRAWTEXT(CROSS(90,操盘线),90,'跑吧');

DRAWICON(CROSS(VAR2,VAR3)AND 操盘线20 AND 获利比REF(获利比,1),3,1);

DRAWTEXT(CROSS(快线,0),10,'金叉');

DRAWTEXT(CROSS(100,快线) AND 操盘线60 AND 一天线REF(一天线,1),100,'死叉');

短线追涨:STICKLINE(REF(VAR7,1)=0 AND VAR70,0,20,6,0);

VARE:=REF(LOW,1)*0.9;

VARF:=LOW*0.9;

VAR10:=(VARF*VOL+VARE*(CAPITAL-VOL))/CAPITAL;

VAR11:=EMA(VAR10,30);

VAR12:=VAR11-CLOSE;

VAR13:=REF(CLOSE,1);

VAR14:=SMA(MAX(CLOSE-VAR13,0),7,1)/SMA(ABS(CLOSE-VAR13),7,1)*100;

VAR15:=SMA(MAX(CLOSE-VAR13,0),13,1)/SMA(ABS(CLOSE-VAR13),13,1)*100;

VAR16:=BARSCOUNT(CLOSE);

VAR17:=SMA(MAX(CLOSE-REF(CLOSE,1),0),6,1)/SMA(ABS(CLOSE-REF(CLOSE,1)),6,1)*100;

VAR18:=((-100)*(HHV(HIGH,60)-CLOSE)/(HHV(HIGH,60)-LLV(LOW,60))+50)*2;

VAR19:=(CLOSE-LLV(LOW,15))/(HHV(HIGH,15)-LLV(LOW,15))*100;

VAR1A:=(SMA(VAR19,4,1)-50)*2;

VAR1B:=SMA(VAR1A,3,1);

VAR1C:=(INDEXC-LLV(INDEXL,14))/(HHV(INDEXH,14)-LLV(INDEXL,14))*100;

VAR1D:=SMA(VAR1C,4,1);

VAR1E:=SMA(VAR1D,3,1);

VAR1F:=(HHV(HIGH,30)-CLOSE)/CLOSE*100;

VAR20:=IF(VAR17=25 AND VAR18-95 AND VAR1F20 AND VAR1B-30 AND VAR1E30 AND VAR12=-0.25 AND VAR1422 AND VAR1528 AND VAR1650,80,0);

导弹: VAR20;

LC:=REF(CLOSE,1);

RSI5:=((SMA(MAX((CLOSE - LC),0),5,1) / SMA(ABS((CLOSE - LC)),5,1)) * 100);

R:=SUM(MAX(MAX((HIGH - LOW),ABS((HIGH - REF(CLOSE,1)))),ABS((LOW - REF(CLOSE,1)))),10);

HD:=(HIGH - REF(HIGH,1));

LD:=(REF(LOW,1) - LOW);

DMP:=SUM(IF(((HD 0) AND (HD LD)),HD,0),10);

DMM:=SUM(IF(((LD 0) AND (LD HD)),LD,0),10);

PDI:=((DMP * 100) / R);

MDI:=((DMM * 100) / R);

ADX:=MA(((ABS((MDI - PDI)) / (MDI + PDI)) * 100),5);

AV:=(RSI5 + ADX);

DXR:=(((ADX + REF(ADX,5)) / 2) + RSI5);

WR10:=((100 * (HHV(HIGH,10) - CLOSE)) / (HHV(HIGH,10) - LLV(LOW,10)));

NEWVOL:=(RSI5 - WR10);

阶段底部:=(AV + NEWVOL);

趋势线:=LLV(阶段底部,1);

IF(CROSS(趋势线,0),50,0);

主力动向指标公式

由于公式引用"XMA(X,N)"未来数据代码,是无法进行准确选股和优化,选取出来的结果也是会漂移不定,公式适宜观赏或教学。

求通达信软件选股公式,高手请进~~~~~

要求太多了,我只找到一个接近要求的,图片演示在下面网址里.

A:=CURRBARSCOUNT;

A1:=DAY!=REF(DAY,1);

A2:=BARSLAST(A1)+1;

A3:=MA(C,A2);

A4:=SUM(AMO,A2)/SUM(VOL,A2)/100;

A5:=IF(CAPITAL0,A4,A3);

均价线:=IF(A=CONST(A2),A5,DRAWNULL);

分钟有效周期:=IF(PERIOD=2,15,IF(PERIOD=3,30,IF(PERIOD=4,60,IF(PERIOD=5,240,DRAWNULL))));

分时价:=TFILT(CLOSE,CURRBARSCOUNT,00,CURRBARSCOUNT,00);

分时判断:=IF(分时价=DRAWNULL,1,IF(分钟有效周期=DRAWNULL,DRAWNULL,1));

{-----------------------------由MACD定位顶底 -------------------------------}

DIFF:=EMA(CLOSE,12)-EMA(CLOSE,26);

DEA:=EMA(DIFF,9);

MACD:=2*(DIFF-DEA);

KX:=BARSSINCE(CLOSE);{←首次开盘价距金的天数}

HHN:=CONST(HHV(DIFF,KX));

HLN:=CONST(LLV(DEA,KX));

RC1:=CONST((HHN+HLN)/2);

SS:=((HHN-HLN)/200);

MACD底部:=(-100*SS+RC1)+-(-100*SS+RC1),COLOR669999;

MACD顶部:=(100*SS+RC1)+-(-100*SS+RC1),COLORFF0033;

MACD中轴:=0+-(-100*SS+RC1);

DIFF修正:=DIFF+-(-100*SS+RC1),COLOR008080;

DEA修正:=DEA+-(-100*SS+RC1),COLOR00FF00;

MACD修正:=2*(DIFF修正-DEA修正)+MACD中轴,COLOR0000BB,NODRAW;

MACD超跌:=CONST(LLV(MACD修正,KX));

MACD超跌线:=IF(MACD超跌MACD底部,MACD超跌,MACD底部);

{----------------------利用MACD趋势进行精确顶底判断 ------------------------}

顶部:=MACD顶部+-MACD超跌线;

天际:=顶部*0.809;

中轴:=MACD中轴+-MACD超跌线;

海面:=顶部*0.191;

底部:=MACD底部;

{------------------------传统KDJ指标结合MACD优化 ---------------------------}

RSVA:=(CLOSE-LLV(LOW,21))/(HHV(HIGH,21)-LLV(LOW,21))*顶部;{采用21日月线优化}

K:SMA(RSVA,3,1),COLORFFFFFF,NODRAW;

D:SMA(K,3,1),COLOR00FFFF,NODRAW;

原J值参数:=3*K-2*D;

JD:=IF(原J值参数底部,底部,原J值参数);{J值底部钝化处理}

J:IF(JD顶部,顶部,JD),COLORFF00FF,NODRAW;{底部钝化处理后再进行顶部钝化处理}

{---------------------------MACD多空量能判断-------------------------------}

MACD多头:DIFF修正+-MACD超跌线,COLOR339999;

空头:DEA修正+-MACD超跌线,COLOR00FF00;

量能柱:2*(MACD多头-空头)+中轴,COLOR0000BB,NODRAW;

超前DEA:=(EMA(MACD多头,7));

超前MACD:=2*(MACD多头-超前DEA)+中轴;

{-----------------------------------大盘动向-------------------------------}

VAR1大盘:=LLV(LOW,13);

VAR2大盘:=HHV(HIGH,13);

VAR3大盘:=(SMA((CLOSE-VAR1大盘)/(VAR2大盘-VAR1大盘)*顶部,5,1))-顶部/2;

VAR4大盘:=SMA((VAR2大盘-CLOSE)/(VAR2大盘-VAR1大盘)*顶部,5,1)-顶部/2;

大盘散户:=IF(VAR4大盘底部,底部,VAR4大盘),COLOR408000;

大盘主力:=IF(VAR3大盘底部,底部,VAR3大盘),COLOR330088;

{---------------------------------密集成本突破-----------------------------}

最高获利参数:=顶部/100;

VAR1C:=(COST(89)-COST(11))*最高获利参数;

VAR2C:=(COST(99.9)-COST(1))*最高获利参数;

单峰:=((1-VAR1C/VAR2C))*顶部;

低密:=((COST(90)-COST(60))/VAR2C)*顶部;

高密:=((COST(40)-COST(1))/VAR2C)*顶部;

赢利:= (SMA(WINNER(AMOUNT/VOL/99),2,1))*顶部;

活跃度:顶部-顶部/(1+EXPMA(HSL,21)),COLOR774455; {←CYF公众追涨热情指标}

70%成本集中度:=IF(VAR1C顶部,顶部,VAR1C),COLORFFFFFF;

90%成本集中度:=IF(VAR2C顶部,顶部,VAR2C),COLORFF0000;

套牢筹码上升:=IF((单峰-赢利)底部,(单峰-赢利),底部);

个股散户:=IF(套牢筹码上升顶部,顶部,套牢筹码上升),COLOR408000;

散户:IF(个股散户=DRAWNULL,DRAWNULL,个股散户),COLOR408000;

获利筹码上升:=IF((赢利-单峰)底部,(赢利-单峰),底部);

个股主力:=IF(获利筹码上升顶部,顶部,获利筹码上升),COLOR330088;

主力:IF(个股主力=DRAWNULL,DRAWNULL,个股主力),COLOR330088;

{--------------------换手率,五日换手率辅助判断个股活跃度-------------------}

换手:SUM(VOL,1)/CAPITAL*100,COLOR666666,NODRAW;

⑤日换:SUM(VOL,5)/CAPITAL*100,COLOR999999,NODRAW;

{----------------------密集成本突破指标筹码峰画线--------------------------}

金色背景修边1:STICKLINE(C0 AND CURRBARSCOUNT=2,顶部,底部,3.05,0),COLOR003333;

金色背景修边2:STICKLINE(C0 AND CURRBARSCOUNT=2,顶部,中轴,3.05,0),COLOR003333;

金色背景补充:DRAWBAND(顶部,RGB(51,51,0),中轴,RGB(51,51,0));

金色背景:DRAWBAND(顶部,RGB(51,51,0),底部,RGB(128,128,128));

追涨热度峰紫色:DRAWBAND(活跃度,RGB(66,52,81),底部,RGB(204,0,0));

高密峰墨蓝色:=DRAWBAND(高密,RGB(0,0,51),底部,RGB(0,0,255));

低密峰纯蓝色:=DRAWBAND(低密,RGB(0,0,102),底部,RGB(0,0,255));

90%成本峰:DRAWBAND(90%成本集中度,RGB(0,0,153),底部,RGB(0,0,153));

70%成本峰:DRAWBAND(70%成本集中度,RGB(0,128,0),底部,RGB(255,255,255));

散户峰绿色:DRAWBAND(散户,RGB(0,64,0),底部,RGB(204,0,0));

主力峰红色:DRAWBAND(主力,RGB(102,26,51),底部,RGB(0,0,255));

MACD多空趋势:DRAWBAND(MACD多头,RGB(204,51,51),空头,RGB(0,179,0));

MACD多头重画:DRAWBAND(MACD多头,RGB(153,153,51),MACD多头,RGB(153,153,51));

MACD空头重画:DRAWBAND(空头,RGB(0,204,0),空头,RGB(0,204,0));

{--------创幻论坛‘131488’会员提供的通达信■新宝塔线■-----原码-----------}

VAR1:=CLOSEREF(CLOSE,1) AND CLOSEREF(CLOSE,2);

VAR2:=REF(VAR1,1) AND CLOSE=REF(CLOSE,1) AND CLOSE=REF(CLOSE,2);

VAR3:=REF(VAR2,1) AND CLOSE=REF(CLOSE,1) AND CLOSE=REF(CLOSE,2);

VAR4:=REF(VAR3,1) AND CLOSE=REF(CLOSE,1) AND CLOSE=REF(CLOSE,2);

VAR5:=REF(VAR4,1) AND CLOSE=REF(CLOSE,1) AND CLOSE=REF(CLOSE,2);

VAR6:=REF(VAR5,1) AND CLOSE=REF(CLOSE,1) AND CLOSE=REF(CLOSE,2);

VAR7:=REF(VAR6,1) AND CLOSE=REF(CLOSE,1) AND CLOSE=REF(CLOSE,2);

VAR8:=REF(VAR7,1) AND CLOSE=REF(CLOSE,1) AND CLOSE=REF(CLOSE,2);

VAR9:=REF(VAR8,1) AND CLOSE=REF(CLOSE,1) AND CLOSE=REF(CLOSE,2);

VARD:=CLOSEREF(CLOSE,1) AND CLOSEREF(CLOSE,2);

VARE:=REF(VARD,1) AND CLOSE=REF(CLOSE,1) AND CLOSE=REF(CLOSE,2);

VARF:=REF(VARE,1) AND CLOSE=REF(CLOSE,1) AND CLOSE=REF(CLOSE,2);

VAR10:=REF(VARF,1) AND CLOSE=REF(CLOSE,1) AND CLOSE=REF(CLOSE,2);

VAR11:=REF(VAR10,1) AND CLOSE=REF(CLOSE,1) AND CLOSE=REF(CLOSE,2);

VAR12:=REF(VAR11,1) AND CLOSE=REF(CLOSE,1) AND CLOSE=REF(CLOSE,2);

VAR13:=REF(VAR12,1) AND CLOSE=REF(CLOSE,1) AND CLOSE=REF(CLOSE,2);

VAR14:=REF(VAR13,1) AND CLOSE=REF(CLOSE,1) AND CLOSE=REF(CLOSE,2);

VAR15:=REF(VAR14,1) AND CLOSE=REF(CLOSE,1) AND CLOSE=REF(CLOSE,2);

VAR16:=REF(VAR15,1) AND CLOSE=REF(CLOSE,1) AND CLOSE=REF(CLOSE,2);

VAR17:=REF(VAR16,1) AND CLOSE=REF(CLOSE,1) AND CLOSE=REF(CLOSE,2);

VAR18:=REF(VAR17,1) AND CLOSE=REF(CLOSE,1) AND CLOSE=REF(CLOSE,2);

三平底翻金:=(REF(VARD OR VARE OR VARF OR VAR10 OR VAR11 OR VAR12 OR VAR13 OR VAR14 OR VAR15 OR VAR16 OR VAR17 OR VAR18,1))

AND VAR1;

主力启动线:=MA(V,5),COLORFFFFFF;

主力洗盘线:=MA(V,35),COLOR00FFFF;

资金异动线:=MA(V,135),COLORFF0000;

{----------------------------买卖参考--------------------------------------}

出击:=(CROSS(主力启动线,资金异动线) OR ((主力洗盘线 资金异动线) AND CROSS(主力启动线,主力洗盘线))),COLORYELLOW;

启动:=(主力启动线REF(主力启动线,1) AND (CROSS(VOL,主力启动线) AND (REF(VOL,1)REF(资金异动线,1) OR REF(VOL,2)REF(资金异动线,2)))),COLOR45AAEE;

成立:=三平底翻金 AND (出击 OR 启动);

买入提示:=IF(成立=1,海面*0.5,0) AND 分时判断=1;

{------------------------顶部线,天际线,海面线,底部线重画-------------------}

顶部线:DRAWBAND(顶部,RGB(51,0,255),顶部,RGB(51,0,255));

天际线:DRAWBAND(天际,RGB(128,64,64),天际,RGB(128,64,64));

海面线:DRAWBAND(海面,RGB(0,153,153),海面,RGB(0,153,153));

底部线:DRAWBAND(0,RGB(153,153,102),买入提示,RGB(153,153,102));

{------------------------超前MACD多空量能柱--------------------------------}

超前MACD红柱1:STICKLINE(超前MACD=中轴,超前MACD,中轴,1.50,0),COLOR226688;

超前MACD红柱2:STICKLINE(超前MACD=中轴,超前MACD,中轴,0.95,0),COLOR4488BB;

超前MACD红柱3:STICKLINE(超前MACD=中轴,超前MACD,中轴,0.31,0),COLOR55AADD;

超前MACD兰柱1:STICKLINE(超前MACD=中轴,超前MACD,中轴,1.50,0),COLOR006600;

超前MACD兰柱2:STICKLINE(超前MACD=中轴,超前MACD,中轴,0.95,0),COLOR007700;

超前MACD兰柱3:STICKLINE(超前MACD=中轴,超前MACD,中轴,0.31,0),COLOR008800;

{--------------------------MACD多空量能柱----------------------------------}

MACD红柱1:STICKLINE(量能柱=中轴,量能柱,中轴,1.5,0),COLOR000077;

MACD红柱2:STICKLINE(量能柱=中轴,量能柱,中轴,1.1,0),COLOR000088;

MACD红柱3:STICKLINE(量能柱=中轴,量能柱,中轴,0.6,0),COLOR000099;

MACD红柱4:STICKLINE(量能柱=中轴,量能柱,中轴,0.15,0),COLOR0000AA;

MACD兰柱1:STICKLINE(量能柱=中轴,量能柱,中轴,1.5,0),COLORAA6633;

MACD兰柱2:STICKLINE(量能柱=中轴,量能柱,中轴,1.1,0),COLORBB7744;

MACD兰柱3:STICKLINE(量能柱=中轴,量能柱,中轴,0.6,0),COLORCC8855;

MACD兰柱4:STICKLINE(量能柱=中轴,量能柱,中轴,0.15,0),COLORDD9966;

{---------中轴线重画及顶部线,天际线,海面线,底部线,多空线文字说明-----------}

中轴线:DRAWBAND(中轴,RGB(128,128,255),中轴,RGB(128,128,255));

顶部线文字:DRAWTEXT(CURRBARSCOUNT=1,顶部*0.98,' 顶部线'),COLORFF0033;

天际线文字:DRAWTEXT(CURRBARSCOUNT=1,天际*0.98,' 天际线'),COLOR404080;

海面线文字:DRAWTEXT(CURRBARSCOUNT=1,海面,' 海面线'),COLOR999900;

底部线文字:DRAWTEXT(CURRBARSCOUNT=1,底部,' 底部线'),COLOR669999;

中轴线文字:DRAWTEXT(CURRBARSCOUNT=1,中轴,' 多空线'),COLORFF8080;

{-------------------------------传统KDJ指标线重画--------------------------}

D线重画:DRAWBAND(D,RGB(255,255,0),D*0.998,RGB(255,255,0));

K线重画:DRAWBAND(K,RGB(255,255,255),K,RGB(255,255,255));

J线重画:DRAWBAND(J,RGB(255,0,255),J,RGB(255,0,255));